Fehlerbehebung Anwendungsbenutzerhilfe auf SharePoint-Server

Anwendungsbenutzerhilfe No ResultsGestern bin ich über ein sehr spezifisches Problem im Zusammenhang mit der Installation vom Microsoft Dynamics AX 2012 Help Server auf einer Maschine, die bereits SharePoint beinhaltet gestoßen. Das Problem stellt sich so dar, dass trotz aller Bemühungen immer nur No results – The requested topic could not be found. angezeigt wird.

Ich habe eine neue Website in IIS (Internet Information Services) erstellt und dann den AX-Installer verwendet, um die Hilfe zu installieren. Ich habe dabei – analog zu den Seiten, die durch den vorhandenen SharePoint schon da waren, für die Website ein neues Verzeichnis erstellt, etwa C:\inetpub\wwwroot\wss\VirtualDirectories\12345. Ich wusste natürlich nicht, dass es ein bekanntes Problem gibt, das sich auf diese sehr spezielle Konstellation bezieht. Diese ist im Microsoft Dynamics AX Technical Support Blog beschrieben:

d. This is very strange but if help server content is installed in directory of SharePoint ie: C:\inetpub\wwwroot\wss\VirtualDirectories\8082\DynamicsAX6HelpServer\Content the Search Service does not return correct files and the Help Server does not work correctly. So far we have no idea why does it happen but the workaround is to uninstall Help Server and install it on Web Application which physical path points to ie: C:\inetpub\wwwroot\8082\DynamicsAX6HelpServer\Content

Wie gesagt, ich wusste nichts davon und habe mich einige Zeit damit herumgeärgert. Tatsächlich war ich zwischendurch der Meinung, nach Neuaufbau des Index und dem Setzen von mehreren verschiedenen Kombinationen von Berechtigungen auf den Ordnern 12345 und DynamicsAX6HelpServer das Problem behoben zu haben. Aber ich musste heute feststellen, dass das wieder nicht mehr funktionierte! Wie bizarr! Tatsächlich habe ich letztendlich kapituliert und die Hilfen deinstalliert, die Website über IIS gelöscht und alles noch einmal in einem anderen Verzeichnis neu aufgebaut. Seitdem die Indizierung durchgelaufen ist, funktioniert die Anzeige von Hilfedateien jetzt endlich auch wie erwartet 🙂

Schreibe einen Kommentar